Push Cash

Services are down / unavailable
Monitoring·Degraded performance

seeing partial recovery of the API

Tue, Oct 21, 2025, 03:34 AM
(1 month ago)
·
Affected components
Payment Processing
Updates

Monitoring

seeing partial recovery of the API

Tue, Oct 21, 2025, 03:34 AM

Monitoring

Seeing regression from AWS, payment processing unavailable

Mon, Oct 20, 2025, 11:58 PM(3 hours earlier)

Monitoring

We are seeing recovery in payment processing due to AWS services coming back online, continuing to monitor the situation

Mon, Oct 20, 2025, 10:09 PM(1 hour earlier)

Investigating

We are experiencing an outage related to the AWS outage in us-east-1 - while push does not run services in this region, we have 3rd party dependencies which do and are critical to our services, causing a cascading failure.

Will continue to work with our providers and AWS to resolve the issue

Mon, Oct 20, 2025, 09:01 PM(1 hour earlier)
Powered by